Introduction

Requirements

The following software is required to use RT-Component Builder (RTCBuilder).

Java Development Kit 6 Note: Java 1.5 (5.0) is not suitable.
Eclipse 3.2. or higher
http://www.eclipse.org/downloads/index.php
http://archive.eclipse.org/eclipse/downloads/index.php
Eclipse IDE
Eclipse EMF 2.2 or higher (including SDO and XSD) Eclipse plugin required by RTC Builder
Note: be sure to use versions that match your Eclipse version.
Eclipse GEF 3.2 or higher(including Draw2D) Eclipse plugin required by RTC Builder
Note: be sure to use versions that match your Eclipse version.

If you will be generating components for C++ or Python, you will need the following as well:

Software Remarks
Eclipse CDT C++ development environment
Pydev for Eclipse Python development environment

Limitations

RTCBuilder is designed for OpenRTM-aist. It may not work with other RTC platforms.

Download

latest Releases

For Begginers

Windows msi(installer) package (only trying samples)

C++,Python,Java,
Toolsを含む
1.2.1-RELEASE

Development environment is required for RT-Component development. See download page for details.

Number of Projects

Choreonoid

Motion editor/Dynamics simulator

OpenHRP3

Dynamics simulator

OpenRTP

Integrated Development Platform

AIST RTC collection

RT-Components collection by AIST

TORK

Tokyo Opensource Robotics Association

DAQ-Middleware

Middleware for DAQ (Data Aquisition) by KEK